Предупреждение при использовании pip

Vershitel_sudeb

Пользователь
Пользователь
Мар 17, 2021
42
9
8
Каждый раз при использовании pip появляется сообщение:

WARNING: Value for scheme.headers does not match. Please report this to <https://github.com/pypa/pip/issues/9617>
distutils: C:\Users\danila\AppData\Roaming\Python\Python39\Include\UNKNOWN
sysconfig: C:\Users\danila\AppData\Roaming\Python\Python39\Include
WARNING: Additional context:
user = True
home = None
root = None
prefix = None

Кто-нибудь сталкивался с таким? Как это решить/убрать?
 

regnor

Модератор
Команда форума
Модератор
Июл 7, 2020
847
135
43
откатитесь на предыдущую версию, обычно помогает
 

LekoB

Новичок
Пользователь
Апр 29, 2021
3
0
1
откатитесь на предыдущую версию, обычно помогает
Но выдаёт другую ошибку:
WARNING: You are using pip version 20.2.4; however, version 21.1 is available.
You should consider upgrading via the 'c:\users\user\appdata\local\programs\python\
python39\python.exe -m pip install --upgrade pip' command.
 

regnor

Модератор
Команда форума
Модератор
Июл 7, 2020
847
135
43
Но выдаёт другую ошибку:
WARNING: You are using pip version 20.2.4; however, version 21.1 is available.
You should consider upgrading via the 'c:\users\user\appdata\local\programs\python\
python39\python.exe -m pip install --upgrade pip' command.
это не ошибка, а предупреждение, что вы используете не актуальную версию pip, это не критично...
 

Форум IT Специалистов